const regex = /Need to process image tag.*\?custId=(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Need to process image tag.*\\?custId=(\\d+)', 'gm')
const str = `Need to process image tag <img src=\\"http://danny.oz.au/p/56214815-tripod.jpg?custId=1235\\"/>
Need to process image tag <img src=\\"http://danny.oz.au/p/56214815-tripod.jpg?custId=123445\\"/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}