// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Need to process image tag.*\?custId=(\d+)").unwrap();
let string = "Need to process image tag <img src=\\\"http://danny.oz.au/p/56214815-tripod.jpg?custId=1235\\\"/>
Need to process image tag <img src=\\\"http://danny.oz.au/p/56214815-tripod.jpg?custId=123445\\\"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}