package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Need to process image tag.*\?custId=(\d+)`)
var str = `Need to process image tag <img src=\"http://danny.oz.au/p/56214815-tripod.jpg?custId=1235\"/>
Need to process image tag <img src=\"http://danny.oz.au/p/56214815-tripod.jpg?custId=123445\"/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}