#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\\)(?:\\{2})*\$"
Local $sString = "$test - should match, variable usage" & @CRLF & _
"redis://$REDIS_IP:4334 - should match, variable substitution" & @CRLF & _
"tes\$t - shouldn't match, passwords and such" & @CRLF & _
"test${somemore} - should match, variable expansion"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")