import Foundation
let pattern = #"(?<!\\)(?:\\{2})*\$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$test - should match, variable usage
redis://$REDIS_IP:4334 - should match, variable substitution
tes\$t - shouldn't match, passwords and such
test${somemore} - should match, variable expansion
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)