using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(?:\\{2})*\$";
string input = @"$test - should match, variable usage
redis://$REDIS_IP:4334 - should match, variable substitution
tes\$t - shouldn't match, passwords and such
test${somemore} - should match, variable expansion";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}