re = /(?<!\\)(?:\\{2})*\$/
str = '$test - should match, variable usage
redis://$REDIS_IP:4334 - should match, variable substitution
tes\\$t - shouldn\'t match, passwords and such
test${somemore} - should match, variable expansion'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end