use strict;
my $str = '$test - should match, variable usage
redis://$REDIS_IP:4334 - should match, variable substitution
tes\\$t - shouldn\'t match, passwords and such
test${somemore} - should match, variable expansion';
my $regex = qr/(?<!\\)(?:\\{2})*\$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}