$re = '/(?<!\\\\)(?:\\\\{2})*\$/';
$str = '$test - should match, variable usage
redis://$REDIS_IP:4334 - should match, variable substitution
tes\\$t - shouldn\'t match, passwords and such
test${somemore} - should match, variable expansion';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);