const regex = /^\D*\d+\K.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\D*\\d+\\K.*', 'gm')
const str = `Hubert 208 apt 1
Mass Av 300, block 3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);