$re = '/^\D*\d+\K.*/m';
$str = 'Hubert 208 apt 1
Mass Av 300, block 3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;