import re
regex = re.compile(r"^\D*\d+\K.*", flags=re.MULTILINE)
test_str = ("Hubert 208 apt 1\n"
"Mass Av 300, block 3")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)