re = /^\D*\d+\K.*/m
str = 'Hubert 208 apt 1
Mass Av 300, block 3'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result