using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE) # start DEFINE block
(?<text>(]\s*)Some\ original\ string(\s*\[))
) # end DEFINE block
##### The regex matching starts here #####
(?&text)";
string input = @"[]Some original string[]";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}