package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?(DEFINE) # start DEFINE block
(?<text>(]\s*)Some\ original\ string(\s*\[))
) # end DEFINE block
##### The regex matching starts here #####
(?&text)`)
var str = `[]Some original string[]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}