// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?(DEFINE) # start DEFINE block
(?<text>(]\s*)Some\ original\ string(\s*\[))
) # end DEFINE block
##### The regex matching starts here #####
(?&text)").unwrap();
let string = "[]Some original string[]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}