re = /(?(DEFINE) # start DEFINE block
(?<text>(]\s*)Some\ original\ string(\s*\[))
) # end DEFINE block
##### The regex matching starts here #####
(?&text)/x
str = '[]Some original string[]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end