$re = '/(?(DEFINE) # start DEFINE block
(?<text>(]\s*)Some\ original\ string(\s*\[))
) # end DEFINE block
##### The regex matching starts here #####
(?&text)/x';
$str = '[]Some original string[]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);