import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE) # start DEFINE block\n"
+ " (?<text>(]\\s*)Some\\ original\\ string(\\s*\\[))\n"
+ ") # end DEFINE block\n\n"
+ "##### The regex matching starts here #####\n"
+ "(?&text)";
final String string = "[]Some original string[]";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}