# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\<Folder id="\w+.*">|\<\\/Folder\>//gm;t' <<< "<Folder id=\"helo \">
Hello
</Folder>
<Folder id=\"rohit (0000)\">
Hello
</Folder>"