#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\<Folder id="\w+.*">|\<\/Folder\>"
Local $sString = "<Folder id="helo ">" & @CRLF & _
"Hello" & @CRLF & _
"</Folder>" & @CRLF & _
"<Folder id="rohit (0000)">" & @CRLF & _
"Hello" & @CRLF & _
"</Folder>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)