const regex = /^\<Folder id="\w+.*">|\<\/Folder\>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\<Folder id="\\w+.*">|\\<\\\/Folder\\>', 'gm')
const str = `<Folder id="helo ">
Hello
</Folder>
<Folder id="rohit (0000)">
Hello
</Folder>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);