import re
regex = re.compile(r"^\<Folder id=\"\w+.*\">|\<\/Folder\>", flags=re.MULTILINE)
test_str = ("<Folder id=\"helo \">\n"
"Hello\n"
"</Folder>\n"
"<Folder id=\"rohit (0000)\">\n"
"Hello\n"
"</Folder>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)