use strict;
my $str = '<Folder id="helo ">
Hello
</Folder>
<Folder id="rohit (0000)">
Hello
</Folder>';
my $regex = qr/^\<Folder id="\w+.*">|\<\/Folder\>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";