#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<((?:[^<>]|(?R))*)>"
Local $sString = "<%@ Page Language="C#" %>" & @CRLF & _
"<td class="c1 c2 c3" colspan="2">" & @CRLF & _
"lorem ipsum" & @CRLF & _
"<div class="d1" id="div2" attrid="<%# Eval("CategoryID") %>">" & @CRLF & _
"testing 123" & @CRLF & _
"</div>" & @CRLF & _
"asdf" & @CRLF & _
"</td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")