re = /<((?:[^<>]|(?R))*)>/
str = '<%@ Page Language="C#" %>
<td class="c1 c2 c3" colspan="2">
lorem ipsum
<div class="d1" id="div2" attrid="<%# Eval("CategoryID") %>">
testing 123
</div>
asdf
</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end