// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<((?:[^<>]|(?R))*)>").unwrap();
let string = "<%@ Page Language=\"C#\" %>
<td class=\"c1 c2 c3\" colspan=\"2\">
lorem ipsum
<div class=\"d1\" id=\"div2\" attrid=\"<%# Eval(\"CategoryID\") %>\">
testing 123
</div>
asdf
</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}