using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<((?:[^<>]|(?R))*)>";
string input = @"<%@ Page Language=""C#"" %>
<td class=""c1 c2 c3"" colspan=""2"">
lorem ipsum
<div class=""d1"" id=""div2"" attrid=""<%# Eval(""CategoryID"") %>"">
testing 123
</div>
asdf
</td>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}