import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<((?:[^<>]|(?R))*)>";
final String string = "<%@ Page Language=\"C#\" %>\n"
+ "<td class=\"c1 c2 c3\" colspan=\"2\">\n"
+ "lorem ipsum\n"
+ "<div class=\"d1\" id=\"div2\" attrid=\"<%# Eval(\"CategoryID\") %>\">\n"
+ "testing 123\n"
+ "</div>\n"
+ "asdf\n"
+ "</td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}