package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(10){1}|([0-9]([.][0-9][0-9]?))$`)
var str = `3.03
02.01
10.0
10.00
1.12
100
5
10.2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}