$re = '/^(10){1}|([0-9]([.][0-9][0-9]?))$/m';
$str = '3.03
02.01
10.0
10.00
1.12
100
5
10.2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);