// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(10){1}|([0-9]([.][0-9][0-9]?))$").unwrap();
let string = "3.03
02.01
10.0
10.00
1.12
100
5
10.2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}