import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(10){1}|([0-9]([.][0-9][0-9]?))$";
final String string = "3.03\n"
+ "02.01\n"
+ "10.0\n"
+ "10.00\n"
+ "1.12\n"
+ "100\n"
+ "5\n"
+ "10.2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}