const regex = /^(10){1}|([0-9]([.][0-9][0-9]?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(10){1}|([0-9]([.][0-9][0-9]?))$', 'gm')
const str = `3.03
02.01
10.0
10.00
1.12
100
5
10.2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}