#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)title = \{(.*)(?<![.?!])\},"
Local $sString = "title = {foo.}," & @CRLF & _
"title = {foo?}," & @CRLF & _
"title = {foo!}," & @CRLF & _
"title = {foo},"
Local $sSubst = "title = \{$1\.\},"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)