const regex = /title = \{(.*)(?<![.?!])\},/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('title = \\{(.*)(?<![.?!])\\},', 'gm')
const str = `title = {foo.},
title = {foo?},
title = {foo!},
title = {foo},`;
const subst = `title = \{$1\.\},`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);