re = /title = \{(.*)(?<![.?!])\},/m
str = 'title = {foo.},
title = {foo?},
title = {foo!},
title = {foo},'
subst = 'title = \\{$1\\.\\},'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result