import Foundation
let pattern = #"title = \{(.*)(?<![.?!])\},"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
title = {foo.},
title = {foo?},
title = {foo!},
title = {foo},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"title = \{$1\.\},"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)