$re = '/title = \{(.*)(?<![.?!])\},/m';
$str = 'title = {foo.},
title = {foo?},
title = {foo!},
title = {foo},';
$subst = "title = \{$1\.\},";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;