use strict;
my $str = 'title = {foo.},
title = {foo?},
title = {foo!},
title = {foo},';
my $regex = qr/title = \{(.*)(?<![.?!])\},/mp;
my $subst = 'title = \\{$1\\.\\},';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";