package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<c:out\s*?value\s*?=\s*?\"\$\{([^\"]+?)\}\"\s*?(?:\><\/c:out>|\/\>)`)
var str = `<c:out value="${tmpChannel.channel.name}" />
<h4><c:out value="${tmpChannel.channel.name}"></c:out></h4>
<h4><a href="${homeLinkUrl}"><c:out></a></h4>
<h4><c:out value="${tmpChannel.channel.name}" /></h4>`
var substitution = "${\1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}