# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<c:out\s*?value\s*?=\s*?\"\$\{([^\"]+?)\}\"\s*?(?:\><\/c:out>|\/\>)"
test_str = ("<c:out value=\"${tmpChannel.channel.name}\" />\n"
"<h4><c:out value=\"${tmpChannel.channel.name}\"></c:out></h4>\n"
"<h4><a href=\"${homeLinkUrl}\"><c:out></a></h4>\n"
"<h4><c:out value=\"${tmpChannel.channel.name}\" /></h4>")
subst = "${\\1}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.