const regex = new RegExp('<c:out\\s*?value\\s*?=\\s*?\\"\\$\\{([^\\"]+?)\\}\\"\\s*?(?:\\><\\/c:out>|\\/\\>)', 'gi')
const str = `<c:out value="\${tmpChannel.channel.name}" />
<h4><c:out value="\${tmpChannel.channel.name}"></c:out></h4>
<h4><a href="\${homeLinkUrl}"><c:out></a></h4>
<h4><c:out value="\${tmpChannel.channel.name}" /></h4>`;
const subst = `${\1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);