use strict;
my $str = '<c:out value="${tmpChannel.channel.name}" />
<h4><c:out value="${tmpChannel.channel.name}"></c:out></h4>
<h4><a href="${homeLinkUrl}"><c:out></a></h4>
<h4><c:out value="${tmpChannel.channel.name}" /></h4>';
my $regex = qr/<c:out\s*?value\s*?=\s*?\"\$\{([^\"]+?)\}\"\s*?(?:\><\/c:out>|\/\>)/ip;
my $subst = '${\\1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";