re = /<c:out\s*?value\s*?=\s*?\"\$\{([^\"]+?)\}\"\s*?(?:\><\/c:out>|\/\>)/i
str = '<c:out value="${tmpChannel.channel.name}" />
<h4><c:out value="${tmpChannel.channel.name}"></c:out></h4>
<h4><a href="${homeLinkUrl}"><c:out></a></h4>
<h4><c:out value="${tmpChannel.channel.name}" /></h4>'
subst = '${\\1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result