import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<c:out\\s*?value\\s*?=\\s*?\\\"\\$\\{([^\\\"]+?)\\}\\\"\\s*?(?:\\><\\/c:out>|\\/\\>)";
final String string = "<c:out value=\"${tmpChannel.channel.name}\" />\n"
+ "<h4><c:out value=\"${tmpChannel.channel.name}\"></c:out></h4>\n"
+ "<h4><a href=\"${homeLinkUrl}\"><c:out></a></h4>\n"
+ "<h4><c:out value=\"${tmpChannel.channel.name}\" /></h4>";
final String subst = "${\\1}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}