#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^col\-(sm|xs|md|lg)\-([1-9]|1[0-2])$"
Local $sString = "col-sm-1" & @CRLF & _
"col-xs-12" & @CRLF & _
"col-md-12" & @CRLF & _
"col-lg-8" & @CRLF & _
"" & @CRLF & _
"col-sms-1" & @CRLF & _
"col-xsd-12" & @CRLF & _
"col-xmd-12" & @CRLF & _
"col-lgd-8" & @CRLF & _
"" & @CRLF & _
"col-sm-17" & @CRLF & _
"col-xs--1" & @CRLF & _
"col-md-0" & @CRLF & _
"col-lg-122" & @CRLF & _
"col-lg-82" & @CRLF & _
"" & @CRLF & _
"col-xs-6" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//^col\-(sm|xs|md|lg)\-(1|2|3|4|5|6|7|8|9|10|11|12)$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")