use strict;
my $str = 'col-sm-1
col-xs-12
col-md-12
col-lg-8
col-sms-1
col-xsd-12
col-xmd-12
col-lgd-8
col-sm-17
col-xs--1
col-md-0
col-lg-122
col-lg-82
col-xs-6
//^col\\-(sm|xs|md|lg)\\-(1|2|3|4|5|6|7|8|9|10|11|12)$';
my $regex = qr/^col\-(sm|xs|md|lg)\-([1-9]|1[0-2])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}