import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^col\\-(sm|xs|md|lg)\\-([1-9]|1[0-2])$";
final String string = "col-sm-1\n"
+ "col-xs-12\n"
+ "col-md-12\n"
+ "col-lg-8\n\n"
+ "col-sms-1\n"
+ "col-xsd-12\n"
+ "col-xmd-12\n"
+ "col-lgd-8\n\n"
+ "col-sm-17\n"
+ "col-xs--1\n"
+ "col-md-0\n"
+ "col-lg-122\n"
+ "col-lg-82\n\n"
+ "col-xs-6\n\n\n"
+ "//^col\\-(sm|xs|md|lg)\\-(1|2|3|4|5|6|7|8|9|10|11|12)$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}