re = /^col\-(sm|xs|md|lg)\-([1-9]|1[0-2])$/m
str = 'col-sm-1
col-xs-12
col-md-12
col-lg-8
col-sms-1
col-xsd-12
col-xmd-12
col-lgd-8
col-sm-17
col-xs--1
col-md-0
col-lg-122
col-lg-82
col-xs-6
//^col\\-(sm|xs|md|lg)\\-(1|2|3|4|5|6|7|8|9|10|11|12)$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end